网站首页

依赖: XXX 但是它将不会被安装

发布时间:2019-4-7 17:11 Sunday编辑:admin阅读(4071)

    1. install aptitude

    sudo apt-get instal aptitude

        下列软件包有未满足的依赖关系:
         aptitude : 依赖: libcwidget3 但是它将不会被安装
                    依赖: libsigc++-2.0-0c2a (>= 2.0.2) 但是它将不会被安装
                    依赖: libxapian22 但是它将不会被安装
                    推荐: apt-xapian-index 但是它将不会被安装
        E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

        sudo apt-get install libcwidget3
        sudo apt-get install libsigc++-2.0-0c2a
        sudo apt-get install libxapian22

    2.

        下列软件包有未满足的依赖关系:
         libboost-all-dev : 依赖: libboost-mpi-dev 但是它将不会被安装
                            依赖: libboost-mpi-python-dev 但是它将不会被安装
                            依赖: libboost-python-dev 但是它将不会被安装
        E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。


        sudo aptitude install libboost-mpi-dev
        sudo aptitude install libboost-mpi-python-dev
        sudo aptitude install libboost-python-dev

    原文:https://blog.csdn.net/xxy0118/article/details/80386829